Leader

Collapse

Announcement

Collapse
No announcement yet.

Problem with Millennium lightbar - only back of bar working

Collapse

300x250 Mobile

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Millennium lightbar - only back of bar working

    I'm working on building up one of our reserve cars and just installed a 911EP Millennium lightbar that I was told was working. Stupid me. Installed it without checking it first. So, now comes the fun part. When I power it on, I only get light from the back of the bar (just the rear, not the ends). When on code 3, the MR8s (the halogens) flash as normal, but still only the back of the bar works. I tried another CID just to make sure, and no change. Also checked the fuses in the bar and all are good and present. Would missing/bad LED modules might cause this? I'm at a dead end and wondering if anyone knew what it might be or what else to check. Thanks!

  • #2
    I work for a company that builds cop cars send pics and spec if you can I'll see what I can come up with.

    Comment


    • #3
      Guides from 911EP:

      Millennium light bar - http://www.911ep.com/PDF/Millennium_InstallTabloid.pdf
      CID controller - http://www.911ep.com/PDF/640004CID_InstallGuide.pdf

      Picture of the Millennium


      These have been discontinued and replaced by the Galaxy.

      Comment


      • #4
        Is it a S&W branded bar or a 911EP branded bar?

        (I'm going from memory here. It's been a while since I've had one of these on my bench)

        The CID box is the "brains" of the bar. It sends a signal to the bar via the gray and blue wires to tell the bar which lights to flash and when.

        There should be four programmable inputs on the CID box. There should be one each for Code1-Code3 and one for a rear flash. You have to actually program a different flash pattern for each of these inputs. There ARE several rear-only flash patterns available on the bar. Double check to make sure they aren't programmed for the positions you're trying to use.

        On the earlier models, you had to manually select the flash pattern to strap to each position. You had to enter programming mode by jumpering a couple terminals on the CID box, turning the bar on to the position you wanted to program, and then momentarily apply power to the programming terminal. Each time you applied power to the terminal, it would advance the flash pattern by one position.

        On the later models, you actually plug the CID box into a PC and program it via software.

        If all else fails, drop me a PM with the serial number of the bar. I'm a 911EP authorized service center.

        Comment


        • #5
          Well, I think I got it fixed, just not sure how/why necessarily. I remember that when we got the bar before I pulled all of the wires from the CID, that there was a power wire jumpered to position #12 which is for programming. So I hit power to it again and the whole bar works now. Not sure what that programming position does, but it seemed to fix the problem. Now I just need to find someone to donate the software/cable to program these for our department ...and I noticed there are more LEDs out in the front. Thanks for the help guys.

          Comment


          • #6
            Originally posted by KE5EHI View Post
            I'm working on building up one of our reserve cars...
            Speaking from experience, it's probably because it's on a reserve car. I've noticed things tend not to work on reserve cars. Sometimes things will be totally missing.

            Comment


            • #7
              Originally posted by Flashaholic View Post
              Speaking from experience, it's probably because it's on a reserve car. I've noticed things tend not to work on reserve cars. Sometimes things will be totally missing.

              Yeah, that's why I'm building it so I can make sure everything is installed right and works. So far so good except the light bar has a few modules out, but I think we're taking it back because it was supposed to be 100% working.

              Comment

              MR300x250 Tablet

              Collapse

              What's Going On

              Collapse

              There are currently 6051 users online. 309 members and 5742 guests.

              Most users ever online was 26,947 at 07:36 PM on 12-29-2019.

              Welcome Ad

              Collapse
              Working...
              X